Интерфейс редактора тестов MyTestXPro

Материал из MyTestXPro Wiki Help
Версия от 21:36, 30 августа 2016; Bas (обсуждение | вклад)

(разн.) ← Предыдущая | Текущая версия (разн.) | Следующая → (разн.)
Перейти к: навигация, поиск
Editor icon.png

Для создания и редактирования тестов в программе имеется удобный редактор тестов. С помощью редактора можно создать либо новый тест, либо изменить существующий. Так же в редакторе настраивается процесс тестирования: порядок заданий и вариантов, ограничение времени, оценивание и многое другое.

При первом запуске программы вы увидите такое окно:

Editor new1.png

Левую часть рабочей области главного окна занимает список групп и заданий. В основной части настраиваются и редактируются параметры теста, групп, задания. Для редактирования группы или задания нужно выбрать ее в списке в левой части окна. Для редактирования параметров теста дать команду в меню Параметры теста.

Каждое задание MyTestXPro находится в той или иной группе. Для того чтобы добавить новое задание необходимо чтобы либо была выбрана группа, в которую будет добавлено задание, либо выбрано другое задание в этой группе. При создании нового теста в нем уже есть одна группа. Для добавления в нее задания нужно ее выбрать, щелкнув по ней.

При выборе какой-либо группы в списке слева в рабочей области редактора тестов отображаются ее параметры (название, описание, ограничение количества заданий для создания выборки и прочее). Для удобства каждой группе можно задать один из десяти цветов ее значка.

Editor new2.png

Изменять параметры группы можно в любой момент. Можно, например, сразу задать ее название и описание, можно сделать это позднее.

Для добавления в группу задания дайте команду Задания → Добавить ... и выберите какого типа задания вы желаете создать. Кроме меню можно воспользоваться соответствующей кнопкой на панели инструментов, либо комбинацией клавиш (например, Alt + 1 для создания задания типа "одиночный выбор"). Тип задания можно изменить позднее, при этом по мере возможности информация не потеряется (например, можно спокойно преобразовать задание типа "одиночный выбор" во "множественный выбор", не потеряв текст вопроса и вариантов ответа).

Editor new3.png Editor new4.png

Большинство типов заданий позволяет видеть их в редакторе почти также как их будет видеть тестируемый в модуле тестирования.

При создании или выборе задания для редактирования в основной части рабочей области окна программы находятся пять вкладок. На первой располагается основная информация о задании: вопрос, количество баллов, ограничение времени, дополнительный рисунок, варианты ответов или критерии проверки ответов (зависит от типа задания).

Вкладка Формулировки позволяет задания для задания до пяти различных формулировок вопроса. Какая из них будет выбрана указывается в параметрах тестирования.

Вкладка Обучение задает обратную связь в обучающем режиме и некоторые его параметры.

Вкладка Дополнительно позволяет прикрепить к заданию звуковой файл и настроить дополнительные параметры.

Editor doptabcrop.png

Вкладка Черновик может использоваться вами для временного хранения частей вопроса или вариантов ответа. Ее содержимое одинаково для всех заданий и не сохраняется в файл.

Внизу рабочей области при создании/редактировании заданий находятся две кнопки - Сохранить и Сбросить. Кнопка Сохранить становится активной если в задание внести какие-либо изменения и позволяет эти изменения сохранить. Кнопка Сбросить отменяет все изменения в задании и выводит его заново так как оно было сохранено последний раз.

Иногда требуется выполнить какие-то действия сразу над несколькими группами или несколькими заданиями. Для этого группы и задания сначала выделить. Выделять можно различными способами: нажать кнопку выделить (внизу списка) для выделения текущего задания, выбирать задания или группы с нажатой клавишей Ctrl или Shift, использовать контекстное меню, которое открывается щелчком правой кнопкой мыши по списку... Выделенные группы и задания отличаются от остальных синей галочкой перед иконкой группы или задания.

Editor new5.png Editor seltask1.png

Что-бы выполнить какие-то действия над выделенными воспользуйтесь подменю Выделенные либо в меню Группы, либо в меню Задания, либо в контекстном меню... Например, так можно задать сразу нескольким заданиям одинаковое количество баллов за верный ответ или ограничение по времени...

Группы и задания можно перемещать либо с помощью кнопок внизу списка, либо перетаскивая их мышью. Причем: если одну группу перетащить на значок другой на значок группы, держа клавишу Alt, то все задания этой группы переместятся в эту группу; если одно из выделенных заданий переместить на значок группы, держа клавишу Alt, то все выделенные задания переместятся тоже в эту группу.

Editor movetask.png Editor movetask2.png

Когда вводится или редактируется вопрос, варианты ответа, формулировки, подсказка, вступление и объяснение ошибки к заданию, описание и справка для группы, описание и комментарии к тесту становится доступна панель форматирования.

Editor panelformat.png

С помощью нее можно быстро отформатировать текст - сделать его жирным, наклонным, курсивом..., поменять цвет, выравнивание, вставить рисунок, символ или таблицу и др. Те же действия можно сделать и с помощью меню Формат или контекстного меню этих полей.

Но может потребоваться больше возможностей. В этом случае можно открыть данный текст во встроенном текстовом редакторе, дав соответствующую команду или просто нажав F4.

Editor open texteditor.png Editor open texteditor2.png

Этот редактор предоставляет больше возможностей по форматированию текста. Формулы можно вставлять как рисунки.

Так же, если в программе установлены словари, то при редактировании текста производится проверка его правописания.

Тесты MyTestXPro хранятся в файлах, один тест - один файл. Для сохранения теста дайте команду Файл → Сохранить или Файл → Сохранить как...

Test icon.png

Если у вас есть готовый тест и из него нужно добавить несколько заданий, то дайте команду Файл → Импорт из другого теста...

Editor import.png

Если вы создали тест и готовы его использовать для тестирования рекомендуется проверить его на наличие возможных ошибок, может где-то забыли отметить верный вариант ответа и т.п. Для этого дайте команду Задания → Проверить все задания... Если будут найдены возможные ошибки они будут показаны в отдельном окне. Щелчок по записи с ошибкой открывает данное задание для редактирования.

Editor check tasks.png

Так же имеется возможность настроить автоматическую проверку заданий при их сохранении или сохранении теста.

Так же рекомендуется вернуться к параметрам теста и еще раз проверить все ли желаемые параметры заданы, может быть вы хотели чтобы варианты заданий перемешивались, но забыли задать данную опцию.

Если нет возможности провести компьютерное тестирование можно создать "бумажные тесты".

Editor test print.png Editor test print2.png

Для самостоятельной подготовки учащихся дома, можно создать автономные (exe) тесты, которые объединяет в себе модуль тестирования и тест, не требует установки и может хранить в себе нужные настройки.


Читайте далее
Right 16.png
Создание заданий в MyTestXPro